We're Here to Help (315) 735-8571

Outdated Browser Alert

Monday, July 24, 2017

In an effort to maintain the highest security standards for our Members through online banking and mobile banking applications, memberONLINE and memberMOBILE will no longer be accessible to Members using the following outdated browsers.
  • Windows Vista or lower operating system
  • Internet Explorer (IE) 7 or lower
  • Android OS earlier version than 5.0
Our records indicate you are using one of the above and will be impacted by this security change. To avoid disruption, it is imperative that you update your systems as soon as possible. Please contact your service provider if needed to do so. The following browsers are supported and recommended:
 
  • IE 11 and Edge
  • Firefox 48 and 47
  • Chrome 50 and 49
  • Safari 9 and 8
If you have any questions you can contact our Member Care Center at 315-735-8571. Thank you for your prompt attention and for enabling us to better serve you.